Headlights and sidelights stopped working

Loom, lights, gauges, indicators & wiring
Post Reply
User avatar
BillG
New Poster
United Kingdom
Posts: 3
Joined: 6 months ago

Headlights and sidelights stopped working

Post by BillG »

Hi all,

The title says it all really, I’ve not got any headlights or sidelights :( - when I pull the switch, nothing happens. I have verified that all bulbs are in working order and not blown, plus checked all connections to the pull switch on the dash, and the dip switch too. All of the bullet connectors are connected securely, so my next step would be to replace the pull switch on the dash, but before I fork out for a new one I thought I’d ask you more knowledgeable folks here if there’s anything else that I ought to check.

It’s worth mentioning that I have recently added a kill switch to the fuel pump circuit, I’m under the impression that this won’t affect the headlights and sidelights, but I may be wrong.

Thank you.



User avatar
Mecanglais
Formally known as chesney
France
Posts: 2235
Joined: 9 years ago
Location: France

Contribution Stars

Re: Headlights and sidelights stopped working

Post by Mecanglais »

A test lamp will be very helpful here.

Are you on the late style toggle switches or the early pull style bakelite ones? I had one once on an early switch where some of the switch had become damaged and fractured which meant the switch wasn't pulling out straight and occasionally making no contact, a piece of plastic card glued over the top made a suitable guide to keep everything where it should be.

The lights (sidelights and headlights) have one feed wire, one of the brown with blue stripe wires from the regulator.(A1 terminal), my first port of call would be to make sure that the connections here are clean and tight.

Failing that, I would pull the switch and.make.sure you are getting 12V to the aforementioned wire at the switch end.

The switch for the pump should have no bearing, it is wired via the non fused side of the ignition live fuse.



User avatar
BillG
New Poster
United Kingdom
Posts: 3
Joined: 6 months ago

Re: Headlights and sidelights stopped working

Post by BillG »

Thanks for the advice, I’ll definitely take a look at that later this week. My switches are the old pull style ones- I took the switch out and it seems fine mechanically, just a little dirty on the inside, which is annoying because I don’t think you can remove the switch from the Black Bakelite housing to clean the contact points, making it a pain to clean.



User avatar
Mecanglais
Formally known as chesney
France
Posts: 2235
Joined: 9 years ago
Location: France

Contribution Stars

Re: Headlights and sidelights stopped working

Post by Mecanglais »

If I remember rightly (although I am talking about ten years since I had it apart) there is a bakelite 'track' for the switch to run in to keep the internals parallel with the terminals at the back, mine was damaged and had to be pulled at an angle, until I glued a bit on, not saying necessarily that that is what you have, just something to look out for.

With these old switches, they've been doing their thing for 60+ years, if you are confident, it might be worth adding some relays to take the load off the switch and give it a bit of a rest.
As with these things, I'm sure they fundamentally can come apart - whether it's a good idea to try it is another thing! There is a chap who restores Series 1 Land Rover ignition/light switches, he makes it look reasonably straight forward but not sure I'd dare to give it a go. Some contact cleaner and a cotton bud or soft brush might work, but as you say, the contact points are inaccessible.



User avatar
frosty
.
Australia
Posts: 614
Joined: 12 years ago
Location: Near a big pineapple ~ Queensland, Australia
Contact:

Contribution Stars

Re: Headlights and sidelights stopped working

Post by frosty »

Check the Earth wire that is fixed in the guard area ( or in the headlight inner bowl ~ can't remember) and give it a clean. Also, there is a little button that you push in on the underside of the bakelite switch that you push in to get it off.

hope that helps


We're friendly ~ have a look see
http://www.morrisdownunder.com/forum/index.php" onclick="window.open(this.href);return false;

User avatar
Custard
.
Ireland
Posts: 2519
Joined: 9 years ago
Location: Blackpool

Contribution Stars

Re: Headlights and sidelights stopped working

Post by Custard »

Have you sidelights at the rear?

If you have as above look for earthing issues.

The easy check is to disconnect all the wires off the switch and connect them together being careful not to short to the metal dash.

If you then get lights its the switch, if not then check for 12v as above.

I assume you really are not getting sidelights or headlights and its not just that the speedo is not lighting up?

If they failed immediately after fitting the kill switch I would carefully check what you have done and if necessary temporarily undo it.

Sean.



Post Reply